CAST AIP Extension and CAST AIP Components Compatibility Matrices

Below matrix gives an overview of compatibility of AIP extensions with AIP versions.

AIP Extension AIP 7.3 AIP 8.0 AIP 8.1
AngularJS 1.0.0-funcrel 7.3.4+ Yes Yes
AngularJS 1.1.0-beta3 7.3.4+ Yes Yes
C and C++ File Discoverer 1.1.0-funcrel 7.3.5+ Yes Yes
CVS File Extractor 2.0.0-funcrel No Yes Yes
EGL 1.0.2 Yes Yes Yes
Entity Framework 1.0.0-beta1 Yes  ( starting from 7.3.7 for C# only) Yes (for C# and VB .Net) Yes (for C# and VB .Net)
Flex 1.0.2 Yes Yes Yes
Fortran 1.0.1 Yes Yes Yes
GIT Extractor 1.2.0-funcrel Yes Yes Yes
Green IT Index 1.0.0-beta1 Yes (starting from 7.3.4) Yes Yes
HTML5/Javascript 1.0.0-funcrel 7.3.4+ Yes Yes
HTML5/Javascript 1.1.0-beta2 7.3.4+ Yes Yes
C/C++/Objective-C 1.0.0-beta2 No Yes Yes
iOS 1.0.0-beta2 No No Yes
JAX-RS 1.0.0-funcrel 7.3.4+ Yes Yes
JAX-RS 1.1.0-beta2 7.3.4+ Yes Yes
JEE File Discoverer 1.1.0-funcrel 7.3.3+ Yes Yes
JEE File Discoverer 1.2.0-funcrel starting from 7.3.3+ Yes Yes
JEE Manifest Discoverer 1.0.3-funcrel Yes Yes Yes
JEE Manifest Discoverer 1.0.4-funcrel Yes Yes Yes
jQuery 1.0.0-funcrel 7.3.4+ Yes Yes
jQuery 1.1.0-beta1 7.3.4+ Yes Yes
Maven HTTP Repository Extractor 1.0.0-funcrel No Yes <unknown>
Maven HTTP Repository Extractor 1.1.0-funcrel No Yes <unknown>
Node.js 1.0.0-funcrel 7.3.4+ Yes Yes
Node.js 1.1.0-beta1 7.3.4+ Yes Yes
PeopleSoft 5.0.2 Yes (starting from 7.3.6) Yes (starting from 8.0.1) Yes (starting from 8.1.1)
PHP 1.0.x Yes Yes Yes
PHP 1.1.0 No Yes Yes
PHP 1.1.1 No Yes yes
PHP 1.1.2 No Yes Yes
PL1 1.0.2 Yes Yes Yes
PL1 1.0.3 Yes Yes Yes
RPG 1.0.3 Yes Yes Yes
RPG 2.0.0 -beta1 No Yes Yes
RPG 2.0.0 No Yes Yes
RPG 2.0.1 No Yes Yes
RPG 2.0.2 No Yes Yes
SAPUI5 1.0.0-alpha2 7.3.4+ Yes Yes
Shell 1.0.x Yes Yes Yes
Siebel 5.0.x ( x <=3) 7.3.6 - 7.3.7 - 7.3.8 8.0.1 only No
Siebel 5.0.4  Yes (starting from 7.3.6) Yes (starting from 8.0.1) Yes (starting from 8.1.1)
Siebel 5.1 Yes (starting from 7.3.8) Yes (starting from 8.0.1) Yes (starting from 8.1.1)
Silverlight 1.0.0-funcrel Yes ( starting from 7.3.7 for C# only) Yes (for C# and VB .Net) Yes (for C# and VB .Net)
Silverlight 1.1.0-funcrel Yes ( starting from 7.3.7 for C# only) Yes (for C# and VB .Net) Yes (for C# and VB .Net)
Spring MVC 1.0.0-funcrel 7.3.4+ Yes Yes
Spring MVC 1.1.0-beta2 7.3.4+ Yes Yes
SQL Analyzer 1.0.0-beta1 No Yes Yes
Tibco 1.0.3 Yes Yes Yes
Tibco 1.1.x Yes Yes Yes
WCF 1.0.0-funcrel Yes ( starting from 7.3.7 for C# only) Yes (for C# and VB .Net) Yes (for C# and VB .Net)
WCF 1.1.0-funcrel Yes ( starting from 7.3.7 for C# only) Yes (for C# and VB .Net) Yes (for C# and VB .Net)
WPF 1.0.0-funcrel Yes ( starting from 7.3.7 for C# only) Yes (for C# and VB .Net) Yes (for C# and VB .Net)
WPF 1.1.0-funcrel Yes ( starting from 7.3.7 for C# only) Yes (for C# and VB .Net) Yes (for C# and VB .Net)

For Report Generator, see CAST Report Generator - Installation Prerequisites 

Have more questions? Submit a request

Comments

Powered by Zendesk